Contribuer

Infos Contribution

Suivre
1 suiveur

Statistiques

Envoyé : 2017-10-20 03:19:08 -0500

Vu : 119 fois

Dernière mise à jour : 2017-10-20 03:31:54 -0500

0

A server error occurred. Please contact the administrator. [fermé]

envoyé 2017-10-20 03:19:08 -0500

Image Gravatar de Raph

Bonjour,

J'ai un problème au lancement de wcs avec la commande manage.py

Le site m'affiche : A server error occurred. Please contact the administrator.

et la console :

Traceback (most recent call last): File "/usr/lib/python2.7/wsgiref/handlers.py", line 85, in run self.result = application(self.environ, self.start_response) File "/root/fe/local/lib/python2.7/site-packages/django/contrib/staticfiles/handlers.py", line 63, in __call__ return self.application(environ, start_response) File "/root/fe/local/lib/python2.7/site-packages/django/core/handlers/wsgi.py", line 197, in __call__ start_response(force_str(status), response_headers) File "/usr/lib/python2.7/wsgiref/handlers.py", line 181, in start_response assert not is_hop_by_hop(name),"Hop-by-hop headers not allowed" AssertionError: Hop-by-hop headers not allowed [20/Oct/2017 10:12:09] "GET HTTP/1.1" 500 59

Cordialement

modifier requalifier réouvrir Supprimer

Cette question a été close pour la raison suivante "la question est résolue, une bonne réponse a été acceptée" par Pierre
Date de clôture : 2017-12-16 23:19:56.665897

Commentaires

1 réponse

Filtrer les contributions : anciennes récentes populaires
0

répondue 2017-10-20 03:31:54 -0500

Entr'ouvert

Apparemment il y a un entête Hop-by-hop qui est ajouté dans votre requête HTTP (plugin particulier dans votre navigateur ?) et ce n'est pas pris en charge par le module "wsgiref" (cette erreur semble uniquement levée en mode "debug", l'entête est ignoré autrement).

modifier Supprimer publié plus

Commentaires

Bonjour Fred Merci de ta rapidité Non je n'est pas de plugin sur mon navigateur et je suis deja en mode debug :s Cordialement

Raph ( 2017-10-20 03:35:28 -0500 )modifier

Peut-être un proxy modifie-t-il alors les entêtes; je n'ai jamais rencontré cette erreur.

Fred ( 2017-10-20 06:03:53 -0500 )modifier

J'ai changé de version de django est sa a réglé le problème un message erreur aparrait : [20/Oct/2017 13:43:44] "GET / HTTP/1.1" 200 335 [20/Oct/2017 13:43:44] "GET /static/xstatic/themes/smoothness/jquery-ui.min.css HTTP/1.1" 404 1840

Raph ( 2017-10-20 06:45:30 -0500 )modifier