Contribuer

Infos Contribution

Suivre
1 suiveur

Statistiques

Envoyé : 2019-10-23 04:18:35 -0500

Vu : 52 fois

Dernière mise à jour : 2019-10-23 04:48:49 -0500

0

Installation publik

envoyé 2019-10-23 04:18:35 -0500

Image Gravatar de HP

Bonjour,

Je souhaite installer une version de Publik pour ma collectivité pour faire un tour d'horizon du potentiel. Malheureusement, je me retrouve bloqué assez rapidement :

  • Pré-requis -> OK
  • Configuration des dépôts -> OK
  • Création des BDD -> Ok
  • Installation des composants -> KO

Dès l'installation de combo, je retrouve confronté à un pb au niveau d'une dépendance

sudo apt install combo
Lecture des listes de paquets... Fait
Construction de l'arbre des dépendances
Lecture des informations d'état... Fait
Certains paquets ne peuvent être installés. Ceci peut signifier
que vous avez demandé l'impossible, ou bien, si vous utilisez
la distribution unstable, que certains paquets n'ont pas encore
été créés ou ne sont pas sortis d'Incoming.
L'information suivante devrait vous aider à résoudre la situation :

Les paquets suivants contiennent des dépendances non satisfaites :
 combo : Dépend: python-combo (= 2.37-1~eob90+1) mais ne sera pas installé
E: Impossible de corriger les problèmes, des paquets défectueux sont en mode « garder en l'état ».

Quand je cherche à installer cette dépendance, j'obtiens :

python-pywebpush : Dépend: python-cryptography (>= 1.8.1) mais 1.7.1-3+deb9u1 devra être installé
                    Dépend: python-http-ece mais ne sera pas installé
                    Dépend: python-py-vapid mais ne sera pas installé

Je peux continuer ainsi l'arbre des dépendances, je me retrouve bloqué...

Je suis sur une Debian 9.11 4.9.0-11-amd64 #1 SMP Debian 4.9.189-3+deb9u1 (2019-09-20) x86_64 GNU/Linux

Y-a-t-il un élément au niveau des pré-requis ou des dépôts que j'aurai omis?

Par avance merci pour votre aide!

Bonne journée,

modifier requalifier fermer Supprimer

2 réponses

Filtrer les contributions : anciennes récentes populaires
0

répondue 2019-10-23 04:24:10 -0500

Entr'ouvert

Bonjour,

Il y a une série de dépendances qui viennent des dépôts stretch-backports mais celles-ci ne sont pas prises en compte automatiquement dans la configuration standard de Debian; vous pouvez installer le paquet entrouvert-repository, il configurera automatiquement cet aspect.

Par ailleurs, pour expérimenter, il est peut-être plus facile de mettre en place un environnement local, la documentation sur le sujet est ici : https://doc-publik.entrouvert.com/dev... et n'hésitez pas à créer des tickets via https://dev.entrouvert.org/projects/p... si jamais vous rencontrez des problèmes.

modifier Supprimer publié plus
0

répondue 2019-10-23 04:48:49 -0500

Image Gravatar de HP

Merci pour votre réponse. Cependant, j'ai bien installé entrouvert-repository :

sudo apt install entrouvert-repository
Lecture des listes de paquets... Fait
Construction de l'arbre des dépendances
Lecture des informations d'état... Fait
entrouvert-repository is already the newest version (0.17-1~eob90+1).
0 mis à jour, 0 nouvellement installés, 0 à enlever et 0 non mis à jour.

Voici le résultat de l'update :

sudo apt update
Atteint:1 http://repository-debian/mirror/security.debian.org/debian-security stretch/updates InRelease
Ign:2 http://repository-debian/mirror/ftp.fr.debian.org/debian stretch InRelease
Atteint:3 http://repository-debian/mirror/ftp.fr.debian.org/debian stretch Release
Atteint:5 http://deb.entrouvert.org stretch InRelease
Atteint:4 http://repository.rudder.io/apt/4.3 stretch InRelease
Lecture des listes de paquets... Fait
Construction de l'arbre des dépendances
Lecture des informations d'état... Fait
All packages are up to date.

Effectivement, je comprends que l'idée de l'environnement local puisse être "facilitante", mais je cherche aussi à identifier la charge de l'exploitation du système.

En vous remerciant encore,

Cdlt,

modifier Supprimer publié plus

Commentaires

Ok, il faudrait la sortie de apt-cache policy python-cryptography python-http-ece; mais pour assurer le suivi ce sera plus facile via un ticket https://dev.entrouvert.org/projects/publik/issues/new (ce site est prévu pour question/réponse immédiate, n'autorise pas de multiples réponses de la même personne).

Fred ( 2019-10-23 04:56:46 -0500 )modifier

Merci, je viens de créer le ticket 37162; Cdlt,

HP ( 2019-10-23 07:52:25 -0500 )modifier
S'identifier/S'inscrire pour répondre