Contribuer

Infos Contribution

Suivre
1 suiveur

Statistiques

Envoyé : 2020-01-21 05:33:58 -0600

Vu : 42 fois

Dernière mise à jour : 2020-01-21 08:50:44 -0600

0

Erreur 403 wcs backoffice management

envoyé 2020-01-21 05:33:58 -0600

Image Gravatar de Vayel

Bonjour,

Je viens d'installer Publik. Le portail agents fonctionne très bien, mais :

  • Je ne vois pas de lien pour créer de démarche
  • Quand je me rends sur https://demarches.xxx/backoffice/mana..., j'obtiens une erreur 403 malgré le fait que je sois connecté en tant qu'admin (cf. pièce jointe) :

    Traceback (most recent call last): File "/usr/lib/python2.7/dist-packages/wcs/compat.py", line 55, in get context = self.get_context_data(**kwargs) File "/usr/lib/python2.7/dist-packages/wcs/views.py", line 36, in get_context_data body = get_publisher().try_publish(get_request()) File "/usr/lib/python2.7/dist-packages/quixote/publish.py", line 253, in try_publish output = self.root_directory._q_traverse(components) File "/usr/lib/python2.7/dist-packages/auquotidien/modules/root.py", line 323, in _q_traverse return Directory._q_traverse(self, path) File "/usr/lib/python2.7/dist-packages/quixote/directory.py", line 63, in _q_traverse return obj._q_traverse(path) File "/usr/lib/python2.7/dist-packages/wcs/backoffice/root.py", line 90, in _q_traverse return super(RootDirectory, self)._q_traverse(path) File "/usr/lib/python2.7/dist-packages/quixote/directory.py", line 91, in _q_traverse return super(AccessControlled, self)._q_traverse(path) File "/usr/lib/python2.7/dist-packages/quixote/directory.py", line 57, in _q_traverse obj = self._q_lookup(component) File "/usr/lib/python2.7/dist-packages/wcs/backoffice/root.py", line 246, in _q_lookup raise errors.AccessForbiddenError() AccessForbiddenError: ???

J'ignore si le problème est lié mais quand je me rends sur l'url de wcs (https://demarches.xxx/) et que je clique sur "Connexion" (https://demarches.xxx/login/), j'obtiens "???". Le problème vient de l'appel à try_publish() dans CompatWCSPublisher.process_request() (https://repos.entrouvert.org/wcs.git/...) qui retourne "TraversalError()" pour le body.

Quand je vais dans l'onglet "Système" (https://hobo.xxx/), je vois bien les six briques : Connexion, Passerelle, Portail agent, Démarches, Compte citoyen et Porte-documents avec tout en vert (DNS, Certificat, Web). En revanche, dans l'onglet "Services", je vois tout sauf wcs.

Merci d'avance !

Un None est attaché : None (prévisualiser) (télécharger)
modifier requalifier fermer Supprimer

1 réponse

Filtrer les contributions : anciennes récentes populaires
0

répondue 2020-01-21 06:57:57 -0600

Entr'ouvert

Bonjour. Il faut vraisemblablement créer un rôle, le donner à l'utilisateur, aller dans l'écran Paramètres, aller dans Permissions d'administration, compléter pour donner accès. Pour une éventuelle suite https://listes.entrouvert.com/wwsympa... est la liste de diffusion pour le support technique communautaire.

modifier Supprimer publié plus

Commentaires

Merci pour la réponse rapide ! Je ne vois rien qui ressemble à "Permissions d'administration". Comment se fait-il que le superuser ne puisse pas accéder aux formulaires ? Dans les logs, j'ai "/saml/metadata unavailable - lasso is not installed". Cela pourrait-il être lié ?

Vayel ( 2020-01-21 07:38:10 -0600 )modifier

Quand je vais dans l'onglet "Système" (https://hobo.xxx/), je vois bien les six briques : Connexion, Passerelle, Portail agent, Démarches, Compte citoyen et Porte-documents avec tout en vert (DNS, Certificat, Web). En revanche, dans l'onglet "Services", je vois tout sauf wcs.

Vayel ( 2020-01-21 08:01:56 -0600 )modifier
S'identifier/S'inscrire pour répondre